RealTime IT News

Report: Snow Leopard exposes Mac users to Flash flaw

apple_snowleopard2.jpg
Source: Apple

Apple's latest operating system, Snow Leopard, which has otherwise garnered rave reviews, downgrades the version of Adobe Flash on a user's system, Graham Clueley, Sophos security expert, said in a blog post that contains a video of the reported action.

That older version of Adobe Flash, version 10.0.23.1, is vulnerable to several attacks, including one caused in part by Microsoft.

"The version you should be running is the latest version of Flash Player for Mac -- 10.0.32.18," Cluley wrote.

Even worse, Apple does not tell users about the software change, according to Cluley. "Mac users are not informed that Snow Leopard has downgraded their version of Flash without permission, and that they are now exposed to a raft of potential attacks and exploits which have been targeted on Adobe's software in recent months," he wrote.

Representatives of Apple (and Adobe, which has only a peripheral role in this story) were not able to immediately respond to a request for comment.

Adobe can help, according to Cluley. "If you're not sure which version of Adobe Flash you have on your computer (whatever operating system you use), take 30 seconds to visit their Web site. Adobe will not only tell you what version of Flash you are running, they will also tell you what version you should be running.

Comment and Contribute